Система лицензирования

 Вперед

Лицензирование программ - это процедура, позволяющая организации или частному лицу установить и использовать программное обеспечение на отдельном компьютере или в сети, в соответствии с лицензионным соглашением. Цель лицензирования - защитить инвестиции предприятия, производящего программное обеспечение.

В программное обеспечение компании ООО "Геотехнологии" встроен специальный механизм, не позволяющий использовать программы в случае нарушения пользователем каких-либо пунктов этого соглашения. К примеру, запуск программ без активации лицензии, обычно приводит к тому, что программное обеспечение работает в демонстрационном режиме, в котором часть функций становится не доступны для пользователя.

Система лицензирования продуктов компании ООО "Геотехнологии" подразумевает под собой регистрацию выданных лицензий в базе данных и активации лицензии на использование программных продуктов компании со стороны пользователей программных продуктов.
Вперед


Типы лицензии

Типы лицензии | Назад | Вперед
Система лицензирования > Типы лицензии |

В программных продуктах ООО "Геотехнологии" возможны следующие типы лицензии: персональная и многопользовательская. Перед использованием программного обеспечения, лицензия должна быть активирована.

Персональная лицензия.

Персональная лицензия позволяет использовать программное обеспечение только на том компьютере, где установлен ключ защиты.

Многопользовательская лицензия.

Многопользовательская лицензия позволяет использовать программное обеспечение в сети с сервером ключей защиты, который позволяет работать одновременно на заранее оговоренном количестве компьютеров.
Назад Вперед


Принципы лицензирования

Принципы лицензирования | Назад | Вперед
Система лицензирования > Принципы лицензирования |

После приобретения программного обеспечения компании ООО "Геотехнологии" и получения дистрибутива, в случае персональной лицензии, пользователь устанавливает на рабочее место приобретенное программное обеспечение. По окончании инсталляции, пользователь должен пройти процедуру активации лицензии, в противном случае, приобретенное программное обеспечение будет работать только в демонстрационном режиме. В случае многопользовательской лицензии, пользователю необходимо установить сервер ключа защиты и активизировать многопользовательскую лицензию на этом компьютере. Защищенные приложения могут устанавливаться на рабочих станциях по мере необходимости.

В программное обеспечение встроен специальный механизм, не позволяющий использовать программы, не прошедшие активации лицензии. В качестве такого механизма выбрана проверка наличия ключа защиты.

Процедура активации лицензии заключается в записи в память ключа защиты информации о конкретной версии программного обеспечения. По окончанию активации лицензии пользователь должен обязательно переслать код-подтверждение завершения активации разработчику программного обеспечения, для того, чтобы, в дальнейшем у него имелась возможность обновить ключ защиты при изменении программного обеспечения.

Производитель в праве выпустить новую версию программного обеспечения, которое предусматривает приобретение новой лицензии и ее активацию.

Note Примечание.

Получение и обновление дистрибутива может быть выполнено средствами интернет.


Активация лицензии

Активация лицензии | Назад | Вперед
Система лицензирования > Активация лицензии |

Активация лицензий - это обмен информацией пользователя с разработчиком программного обеспечения, в результате которого, пользователь обновляет память ключа защиты в соответствии с приобретенной лицензией.

В целом процесс активации лицензии не зависит от типа выбранной лицензии. В случае использования персональной лицензии пользователь выполняет активацию на рабочем месте, а при использовании многопользовательской лицензии, процесс активации должен проходить на компьютере на котором установлен сетевой ключ защиты и сервер ключей защиты.

Активация лицензий выполняется с помощью утилиты дистанционного программирования ключей Guardant (этот файл входит в комплект поставки защищенного приложения). Для успешной работы клиентской утилиты удаленного обновления, на компьютере пользователя, должны быть установлены драйверы ключа защиты, к порту компьютера должен быть подсоединен ключ с кодами доступа разработчика, который поставляется вместе приобретенным программным обеспечением. В том случае, если у конечного пользователя установлено несколько защищенных программ одного разработчика, то в порту необходимо оставить только тот один ключ, который требует обновления.

Активации лицензии состоит из следующих этапов: Создание запроса на обновление, Обновление памяти ключа и Передача кода-подтверждения разработчику.


Создание запроса на обновление

Создание запроса на обновление | Назад | Вперед
Система лицензирования > Активация лицензии > Создание запроса на обновление |

В том случае, если необходимо активизировать персональную лицензию, то пользователь запускает защищенную программу, и в меню "Лицензирование" выбирает пункт "Обновить лицензию". В том случае, если необходимо провести активацию многопользовательской лицензии, то необходимо напрямую запустить утилиту GSRemote.exe на компьютере, на котором установлен ключ защиты и запущен сервер ключей защиты. В остальном, работа с утилитой дистанционного программирования ключей не будет отличаться.

Порядок создания запроса на обновление выполняется последовательно по шагам:

1. Отсоедините подключенные ключи защиты от портов компьютера, оставив только тот, для которого необходимо активизировать лицензию.

2. Запустите защищенное программное обеспечение, и с помощью меню "Лицензирование", выберите пункт "Обновить лицензию".

3. После запуска утилиты на экране появится форма, на которой необходимо выбрать пункт "Начать новую операцию обновления ключа". Нажмите кнопку "Далее" для продолжения работы.

4. Утилитой удаленного программирования будет сгенерирован запрос на обновление (число-вопрос) - последовательность шестнадцатеричных символов, содержащая информацию о ключе.

Запрос на обновление можно сохранить в файле - кнопка "В файл", скопировать в буфер обмена с помощью кнопки "В буфер" или сразу сформировать почтовое сообщение для разработчиков с помощью кнопки "По почте".

5. Полученную информацию пользователь должен передать разработчику на адрес e-mail support@geo-office.ru.

В письме, кроме сгенерированного числа-вопроса на обновление ключа защиты, необходимо указать информацию: Полное название организации или имя физического лица, Адрес, Телефон, Контактное лицо. Запросы без этой информации отделом технического обеспечения обрабатываться не будут.

6. После передачи запроса, работу утилиты можно завершить, кнопка "Завершить", до получения ответа от разработчиков программного обеспечения.

Note Примечание.

Данные в числе-вопросе передаются в закодированном виде и могут быть использованы только один раз.


Обновление памяти ключа

Обновление памяти ключа | Назад | Вперед
Система лицензирования > Активация лицензии > Обновление памяти ключа |

После получения по электронной почте от разработчиков программного обеспечения числа-ответа, пользователь должен обновить память ключа. При этом, выполняется ряд проверок параметров ключа (ID ключа, Общий код и некоторые другие). Этим исключается возможность подмены обновляемого ключа.

После обновления памяти ключа, пользователь должен передать разработчику программного обеспечения код-подтверждение об успешном завершении операции обновления памяти ключа.

Порядок обновление памяти ключа выполняется последовательно по шагам:

1. Запустите защищенное программное обеспечение, и с помощью меню "Лицензирование", выберите пункт "Обновить лицензию".

2. После запуска утилиты на экране появится страница, на которой необходимо выбрать пункт "Продолжить операцию обновления ключа, инициированную во время предыдущего сеанса". Нажмите кнопку "Далее" для продолжения работы.

3. На экране появится страница мастера, содержащая поле для ввода числа-ответа.

Вставьте в поле для ввода полученный от разработчиков по почте число-ответ. Ввод дампа обновления может происходить следующими способами. Из буфера обмена, когда полученный от разработчика ответ можно скопировать в буфер обмена, а затем вставить его в поле ввода с помощью кнопки "Из буфера". Из файла, когда полученный от разработчика ответ, предварительно сохраняется на локальном диске пользователя, а затем, с помощью кнопки "Из файла…", выбирается этот сохраненный файл.

4. После ввода дампа обновления нажмите кнопку "Далее" для продолжения работы.

На этом активация лицензии не заканчивается. Пользователь должен передать кода-подтверждение завершения операции разработчику. Без передачи кода-подтверждения, конечный пользователь лишается возможности дальнейшего обновления ключа, в случае изменении в программном обеспечении.

Note Примечание.

Данные в числе-ответе передаются в закодированном виде и могут быть использованы только один раз.


Передача кода-подтверждения разработчику

Передача кода-подтверждения разработчику | Назад
Система лицензирования > Активация лицензии > Передача кода-подтверждения разработчику |

По окончанию успешной процедуры обновления памяти ключа защиты, программа генерирует код-подтверждение завершения активации. Пользователь должен обязательно переслать код-подтверждение завершения активации разработчику, для того, чтобы, в дальнейшем имелась возможность обновить ключ защиты при изменении программного обеспечения.

Порядок передачи кода-подтверждения разработчику выполняется последовательно по шагам:

1. На предыдущем этапе, утилитой дистанционного обновления будет произведена операция по обновлению памяти ключа. Затем на экране появится последняя страница мастера с итогами выполнения операции и сформированный финальный код-подтверждение, содержащий информацию о результате обновления (успешно/неудачно).

2. Полученную информацию пользователь должен передать разработчику на адрес e-mail support@geo-office.ru.

Код-подтверждение завершения активации можно сохранить в файле - кнопка "В файл", скопировать в буфер обмена с помощью кнопки "В буфер" или сразу сформировать почтовое сообщение для разработчиков приложения с помощью кнопки "По почте".

3. После успешной отправки кода-подтверждения, нажмите "Готово" для закрытия утилиты дистанционного программирования ключей.

Note Примечание.

Данные в коде-подтверждение завершения активации передаются в закодированном виде и могут быть использованы только один раз.
Назад