Установка "Кадастрового офиса"

 Вперед

Перед установкой Автоматизированного Кадастрового Офиса пользователю необходимо определить несколько важных моментов, которые могут повлиять на варианты установки: требуемое аппаратное и программное обеспечение, вариант установки защиты. Если ранее "Кадастровый Офис" уже использовался, возможно понадобится сохранить свои данные и некоторые настройки.

Инсталляция "Кадастрового Офиса" выполняется с помощью программы установки.

После инсталляции "Кадастрового Офиса" необходимо установить ключ защиты и активизировать лицензию.

В этой главе:

Требования к аппаратному обеспечению.

Требования к программному обеспечению.

Инсталляция Кадастрового Офиса.

Состав Кадастрового Офиса.

Обновление.
Вперед


Требования к аппаратному обеспечению

Требования к аппаратному обеспечению | Назад | Вперед
Установка "Кадастрового офиса" > Требования к аппаратному обеспечению |

Автоматизированный Кадастровый Офис (АКО) не накладывает принципиальных ограничений на тип используемого аппаратного обеспечения, должен корректно работать практически на любом современном персональном компьютере. Однако необходимо учитывать следующую конфигурацию аппаратных средств по обеспечению рабочего места пользователя:

Элемент | Минимально | Рекомендуется
Процессор | Pentium III – 667MHz | Pentium IV - 2.2 МГц и выше
Оперативная память | 512 Мб | 2000 Мб
Жесткий диск (свободное пространство) | не менее 10GB | более 10GB
Видеоадаптер | SVGA | SVGA
Монитор | 17" (1152 x 864) | 20" (1024 x 768)

Реально минимальные требования к параметрам аппаратного обеспечения могут быть намного меньше, чем указано в таблице. Практически невозможно точно указать требования к диску и памяти, так как это во многом зависит от типа задач, выполняемых пользователем, и объема данных. При работе с графической информацией, естественно, лучше использовать монитор с большим разрешением.

В качестве защиты от несанкционированного использования и тиражирования, Автоматизированный Кадастровый Офис использует электронные USB ключи Guardant. Могут быть сетевые (один на несколько рабочих мест) и локальные электронные ключи. В том случае, если планируется использовать сетевой ключ защиты, то необходимо учесть и требования к сетевой инфраструктуре, которая должна обеспечить высокоскоростную передачу данных, предпочтительно 100 Мбит/сек.
Назад Вперед


Требования к программному обеспечению

Требования к программному обеспечению | Назад | Вперед
Установка "Кадастрового офиса" > Требования к программному обеспечению |

Автоматизированный Кадастровый Офис (АКО) функционирует на компьютерах оснащенных следующим программным обеспечением:

Элемент | Минимально | Рекомендуется
Операционная система | Microsoft Windows 2000 Service Pack 3 | Microsoft Windows XP / Vista
Microsoft Office | Microsoft Office XP, 2000 (выходные формы в формате MS Word и MS Excel) | Microsoft Office 2003 и выше
Геоинформационная система (ГИС) | ГИС MapInfo Professional или RunTime 7.5 | ГИС MapInfo Professional или RunTime 7.8 и выше
Файловая система | NTFS | NTFS

Для серверного варианта Автоматизированного Кадастрового Офиса - на рабочих местах должна быть установлена клиентская часть MS SQL Server или Oracle. На сервере - Windows 2000 Server, Microsoft SQL Server 7.0 и 2000, Oracle 8i и 9i.

Если при работе в Автоматизированном Кадастровом Офисе используются в качестве исходой информации данные, полученные с других технических или программных средств, может потребоваться установка дополнительного программного обеспечения. К примеру, из формата Credo (компания Credo-Dialogue, Беларусь) необходимо сначала конвертировать в формат ГИС конвертором GIS-Экспорт, входящим в состав пакета Credo. Модуль GIS-Экспорт должен быть установлен на тех рабочих станциях, где эта конвертация будет выполняться. Аналогичная ситуация может быть, если используются данные в других форматах, например, Autocad.


Инсталляция Кадастрового Офиса

Инсталляция Кадастрового Офиса | Назад | Вперед
Установка "Кадастрового офиса" > Инсталляция Кадастрового Офиса |

Инсталляция Кадастрового Офиса выполняется на компьютеры с необходимым программным обеспечением с помощью программы установки и состоит из ряда последующих шагов:

Шаг 1. Запуск программы установки

Шаг 2. Лицензионное соглашение

Шаг 3. Выбор папки

Шаг 4. Выбор ГИС

Шаг 5. Выбор типа ключа

Шаг 6. Установка дополнительных компонентов

Шаг 7. Итоговая информация

Шаг 8. Завершение установки

В результате установки на указанном диске будет создана папка Кадастрового Офиса, в меню программ будет создана папка с ярлыками.

После инсталляции "Кадастрового Офиса" необходимо установить ключ защиты и активизировать лицензию.

Note Примечание

Пользователь, производящий установку АКО, должен иметь права администратора.


Шаг 1. Запуск программы установки

Шаг 1. Запуск программы установки | Назад | Вперед
Установка "Кадастрового офиса" > Инсталляция Кадастрового Офиса > Шаг 1. Запуск программы установки |

С установочного диска запускается программа KadOffice_Setup_4.0.0.exe.

В процессе установки используем кнопки Дальше для перехода к следующему шагу, Назад и Отмена, если нужно вернуться к предыдущему шагу или прервать установку.

Нажимаем Дальше, чтобы продолжить установку.


Шаг 2. Лицензионное соглашение

Шаг 2. Лицензионное соглашение | Назад | Вперед
Установка "Кадастрового офиса" > Инсталляция Кадастрового Офиса > Шаг 2. Лицензионное соглашение |

Ознакомившись с лицензионным соглашением, включаем "Я согласен..." (иначе установка программы будет прервана) и кнопку Дальше


Шаг 3. Выбор папки

Шаг 3. Выбор папки | Назад | Вперед
Установка "Кадастрового офиса" > Инсталляция Кадастрового Офиса > Шаг 3. Выбор папки |

На этом шаге необходимо указать папку, в которую будет установлен Кадастровый Офис.Либо явно указываем путь к папке (Установить Кадастровый Офис в:),

либо, нажав кнопку Изменить..., в стандартном диалоге Windows выбираем нужную папку и нажимаем OK.

Для продолжения установки нажимаем кнопку Дальше.

Note Примечание.

Недопустимо использование в пути или названии папки символа точка.


Шаг 4. Выбор ГИС

Шаг 4. Выбор ГИС | Назад | Вперед
Установка "Кадастрового офиса" > Инсталляция Кадастрового Офиса > Шаг 4. Выбор ГИС |

На этом шаге установки пользователю необходимо выбрать геоинформационную систему, под которой будет работать Кадастровый Офис.

На компьютере пользователя может быть установлено несколько версий ГИС Mapinfo (Professional и/или RunTime). Для корректной работы Кадастровому Офису необходимо зарегистрироваться для кокретной ГИС Mapinfo, следовательно, пользователю необходимо указать версию.

Указанная в списке версия MapInfo являетя зарегистрированной для запуска программ, написанных на языке MapBasic.

После выбора геоинформационной системы, для которой производится инсталляция Кадастрового Офиса, нажмите Далее для продолжения установки.


Шаг 5. Выбор типа ключа

Шаг 5. Выбор типа ключа | Назад | Вперед
Установка "Кадастрового офиса" > Инсталляция Кадастрового Офиса > Шаг 5. Выбор типа ключа |

Необходимо выбрать вариант ключа защиты. Программа Кадастровый Офис защищена от копирования с помощью ключей Guardant. Ключ может устанавливаться на каждое рабочее место - в свободный порт USB, может быть сетевой на сервере или на одном из компьютеров.

Ключ на одно рабочее место - если планируется использовать локальный ключ защиты. В этом случае, ключ защиты должен быть установлен в компьютер, но только после установки драйверов ключа защиты.

Если планируется использовать сетевой ключ, выберите Сетевой ключ. В этом случае, после инсталляции АКО, пользователю необходимо будет выполнить некоторые дополнительные настройки, по активизации сетевого ключа защиты.

Нажимаем Далее, после того, как определились с выбором.


Шаг 6. Установк дополнительных компонентов

Шаг 6. Установк дополнительных компонентов | Назад | Вперед
Установка "Кадастрового офиса" > Инсталляция Кадастрового Офиса > Шаг 6. Установк дополнительных компонентов |

Выбираем, если нужно, дополнительные компоненты Кадастрового Офиса.

Установка драйверов ключа - если обновляется версия Кадастрового Офиса и ключ Gardant ранее использовался, можно не включать.

Установка дополнительных шрифтов - будут установлены True-Type шрифты, которые могут использоваться в качестве условных знаков для оформления точечных объектов MapInfo и для заполнения площадных объектов. Такие же находятся на дистрибутиве MapInfo (UZ*.ttf). Используются для построения условных знаков в Геомастер. При обновлении Кадастрового Офиса, если ранее шрифты были установлены, включать не нужно.

Установка стилей линейных объектов - будет установлен файл стилей линий Mapinfo.pen, использующийся для построения условных знаков в Геомастер. Установленный до этого Mapinfo.pen сохраняется с именем Mapinfo.old. При обновлении Кадастрового Офиса ещё раз устанавливать не нужно.

После выбора компонентов - Дальше

Note Примечание.

По умолчанию Установка дополнительных шрифтов и Установка стилей линейных объектов отключены. Повторная Установка стилей линейных объектов приведёт к тому, что файл Mapinfo.old будет переписан ещё раз,т.е. сохранённый ранее файл стилей линий будет утерян.


Шаг 7. Итоговая информация

Шаг 7. Итоговая информация | Назад | Вперед
Установка "Кадастрового офиса" > Инсталляция Кадастрового Офиса > Шаг 7. Итоговая информация |

После выбора всех параметров выводится итоговая информация. С помощью кнопки "Назад", пользователь может вернуться на любой из этапов установки и изменить параметры.

Если всё правильно, нажатием Дальше продолжаем установку Кадастрового Офиса. Программа установки приступит к копированию файлов на жесткий диск компьютера.

В том случае, если на шаге 6 пользователь установил параметр "Установка драйверов ключа", то после копирования фалов, будет автоматически запускаться программа установки драйверов ключа защиты.

Note Примечание.

После инсталляции "Кадастрового Офиса" необходимо установить ключ защиты и активизировать лицензию.


Шаг 8. Завершение установки

Шаг 8. Завершение установки | Назад | Вперед
Установка "Кадастрового офиса" > Инсталляция Кадастрового Офиса > Шаг 8. Завершение установки |

При успешном завершении копирования файлов, программа установки регистрирует компоненты в системном реестре, и выводит на экран диалог об успешной установке Кадастрового Офиса.

После инсталляции модуля необходимо установить ключ защиты и активизировать лиценцию.

Нажимаем Выход.


Состав Кадастрового Офиса

Состав Кадастрового Офиса | Назад | Вперед
Установка "Кадастрового офиса" > Состав Кадастрового Офиса |

По указанному на шаге 3 пути будет создана папка Кадастрового Офиса. В стандартном варианте, если не указано другое, C:\Kadoffice363.

Папка содержит файлы разных типов, необходимые для работы Кадастрового Офиса, среди них:

.mbx - программы на языке MapBasic;

.tab, .id, .ind, .map, .tab - таблицы Mapinfo, в том числе справочные

.dll - библиотеки

.xls, .dot - шаблоны для отчётов, выводимых в формате MS Excel и Word;

.ini, .spr - файлы настроек и справки.

Особо можно отметить:

arm1.mbx - запуск Кадастрового Офиса, может использоваться для создания ярлыка на рабочем столе.

gorod.spr - текстовый файл, содержащий справочники (виды права, категории земель, виды угодий и т.д.).

mapinfo.prj - доработанный файл проекций Mapinfo, добавлено описание различных зон системы координат 63г и некоторых местных, удалены неиспользующиеся. Им желательно заменить оригинальный файл, установленный вместе с Mapbnfo, не содержащий описания проекций 63г .

tabgen.ini - текстовый файл, в котором описана структура всех таблиц базы Кадастрового Офиса.

Также в папке Кадастрового Офиса находится ряд вложенных папок:

\pen_fonts - файлы стилей линейных и точечных объектов Mapinfo, шрифты;

\RuntimeMenu - настройки меню для Mapinfo Runtime разных версий;

\Setup Guardant - установка драйверов ключа Guardant;

\Uninstall - информация для удаления Кадастрового Офиса;

\Браузеры - настройки браузеров Кадастрового Офиса;

\Графика - стандартные графические элементы отчётов;

\Документация - документация по Кадастровому Офису;

\Интерфейс - настройки интерфейса (меню) Кадастрового Офиса;

\Отчеты списком - генератор отчётных форм (MS Excel);

\Служебные утилиты - утилиты (программы) администрирования базы Кадастрового Офиса;

\Шаблоны - шаблоны отчётных форм (MS Word).

Кроме того, АКО создаёт в системной папке Windows файл \KadOffice\Карты.ini. Текстовый файл содержит названия и пути карт Кадастрового Офиса, к нему АКО может обращаться в процессе работы.


Обновление

Обновление | Назад | Вперед
Установка "Кадастрового офиса" > Обновление |

Перед обновлением Кадастрового Офиса, если он будет устанавливаться в ту же папку, необходимо принять меры для сохранения сделанных изменений (в настройках, шаблонах выходных форм, справочниках и т.п.), если таковые были произведены с предыдущей версией.

Например - если был доработан (изменён) файл справочников gorod.spr, необходимо перед обновлением сохранить его копию, после установки обновления соответствующим образом подкорректировать новый gorod.spr (только не заменяя его сохранённым!).

Если номер версии Кадастрового Офиса при этом изменяется, потребуется повторить процесс активирования лицензии.

В остальном процесс обновление АКО происходит так же, как при установке.

Note Примечание

Поскольку АКО постоянно дорабатывается, в новой версии (даже с тем же номером) может измениться структура таблиц. Поэтому в меню Администратор Кадастрового Офиса имеется пункт "Привести структуру баз в соответствие", что необходимо делать после каждого обновления во избежание ошибок.


Установка ключей защиты Guardant

Установка ключей защиты Guardant | Назад | Вперед

Электронный ключ - это устройство, предназначенное для защиты программ и данных от несанкционированного использования и тиражирования. Электронный ключ подсоединяется к параллельному (LPT) или USB-порту компьютера.

Различаются сетевые и локальные ключи защиты. Локальный ключ устанавливается на один компьютер и позволяет работать с защищенным приложением только на этом рабочем месте. Сетевой ключ устанавливается на сервер или отдельный компьютер, который будет выступать в качестве сервера ключей защиты, и позволяет одновременно нескольким пользователям работать с защищенным приложением. Количество рабочих станций, которые могут одновременно работать с такими приложениями, ограничено количеством лицензий на каждом конкретном электронном ключе.

В этой главе:

Инсталляция драйверов Guardant.

Порядок установки ключей USB.

Порядок установки ключей LPT.

Установка сетевого ключа защиты.

Мониторинг локального ключа.


Инсталляция драйверов Guardant

Инсталляция драйверов Guardant | Назад | Вперед
Установка ключей защиты Guardant > Инсталляция драйверов Guardant |

Установки как локальных, так и сетевых ключей защиты, начинается с инсталляции драйверов для ключей защиты.

Драйверы для ключей Guardant необходимы для работы защищенных программ, которые обращающихся к этому электронному ключу. Во время установки драйвера все приложения должны быть закрыты во избежание ошибки разделения файлов.

Инсталляция драйверов Guardant выполняется с помощью достаточно простого мастера установки и состоит из ряда последовательных шагов:

1. Отключите все USB ключи от портов компьютера.
2. Запустите на исполнение файл (GrdDriver\GrdDriversRU.msi или GrdDriver\Setup.exe), который находятся на диске с дистрибутивом, и следуйте указаниям программы установки.
3. По окончании процесса инсталляции закройте мастер установки.

В том случае, если в системе уже был установлен драйвер Guardant, то после запуска программы установки драйверов, пользователю будут предложены варианты: переустановить или удалить драйвер Guardant. Для "старых" версий драйверов, необходимо переустановить драйвера.

После инсталляции драйверов, следует произвести подключение ключа к разъему компьютера. Более подробно об установки ключей смотри: Порядок установки ключей USB, Порядок установки ключей LPT, Установка сервера ключей защиты.

Note Примечание.

Пользователь, который устанавливает драйверы для ключей защиты, должен обладать правами администратора.


Порядок установки ключей USB

Порядок установки ключей USB | Назад | Вперед
Установка ключей защиты Guardant > Порядок установки ключей USB |

Подключение и отключение ключей Guardant USB может производиться, как при включенном компьютере, так и при выключенном.

USB-ключ следует подсоединять к порту только после инсталляции драйвера Guardant. Если ключ был подсоединен до установки драйвера, и запустился стандартный "Мастер установки USB-устройств", то необходимо извлечь ключ из порта и отменить работу мастера.

Порядок установки ключа USB выполняется последовательно по шагам:

1. Инсталлируйте драйверы для ключа Guardant.
2. При необходимости перезагрузите компьютер.
3. Подсоедините ключ Guardant USB к свободному USB порту. После обнаружения нового устройства для него будут применены установленные драйвера.
4. Убедитесь в том, что защищенное приложение функционирует правильно.

Возможно, на шаге 3 не будет обнаружено новое устройство. В этом случае нужно зайти в "Управление компьютером | Диспетчер устройств | Guardant dongles", щелкнуть на "Guardant Stealth/Net II USB dongle" и удалить его, а затем вновь повторить шаг 3.

Свидетельством того, что USB-ключ был успешно инициализирован операционной системой, является световая индикация ключа. Кроме того, ключ должен появиться в списке оборудования Диспетчера устройств.

Note Примечание.

Работоспособность и наличие ключа можно выполнить с помощью утилиты диагностики.


Порядок установки ключей LPT

Порядок установки ключей LPT | Назад | Вперед
Установка ключей защиты Guardant > Порядок установки ключей LPT |

Подключение и отключение ключей Guardant LPT может производиться, только при выключенном компьютере. Если на компьютере имеется несколько параллельных портов, можно подключать электронный ключ к любому из них.

Порядок установки LPT-ключ выполняется последовательно по шагам:

1. Выключите питание компьютера и периферийных устройств, подключенных к параллельному порту (принтер, сканер).
2. Отключите периферийное устройство от параллельного порта. Разъем электронного ключа типа "вилка" подключите к параллельному порту компьютера. Электронные ключи поддерживают каскадное подключение, т.е. последовательно один к другому (до 10 штук), при этом все они будут доступны для использования. К разъему электронного ключа типа "розетка" подключите периферийное устройство.
3. Включите компьютер и загрузите операционную систему.
4. Инсталлируйте драйверы для ключа Guardant.
5. При необходимости перезагрузите компьютер.
6. Убедитесь в том, что защищенное приложение функционирует правильно.

Note Примечание.

Работоспособность и наличие ключа можно выполнить с помощью утилиты диагностики.


Установка сетевого ключа защиты

Установка сетевого ключа защиты | Назад | Вперед
Установка ключей защиты Guardant > Установка сетевого ключа защиты |

Установка сетевого ключа выполняется на стороне сервера и на стороне клиента. В начале работы по установке, необходимо определить компьютер на котором будет находиться электронный ключ Guardant Net и программный сервер. Это может быть как сервер сети, так и любая рабочая станция.

Защищенное приложение обращается к электронному ключу Guardant Net через специальный программный сервер. Чтобы начать работу, приложение должно зарегистрироваться на сервере ключа. В ходе регистрации сервер проверяет, подсоединен ли к компьютеру ключ с запрашиваемыми параметрами, и уменьшает на 1 значение ресурса лицензий ключа. Если регистрация прошла успешно, приложение нормально работает, в противном случае клиенту возвращается соответствующая ошибка. При завершении работы приложение снимает свою регистрацию с сервера, при этом производится увеличение на 1 значения ресурса лицензий ключа.

Число одновременно работающих клиентских приложений ограничивается сетевым ресурсом ключей Guardant Net. Реальный сетевой ресурс программируется разработчиком перед передачей защищенного приложения и ключа конечному пользователю.

В этом разделе:

Установка сервера ключей защиты.

Настройки на стороне клиента.

Мониторинг сетевого ключа.

Note Примечание.

Подробнее о сервере Guardant Net, его установки и настройки смотри в документе "Руководство системного администратора Guardant Net.pdf".


Установка сервера ключей защиты

Установка сервера ключей защиты | Назад | Вперед
Установка ключей защиты Guardant > Установка сетевого ключа защиты > Установка сервера ключей защиты |

Сервер Guardant Net обеспечивает связь между защищенным сетевым приложением и сетевым ключом Guardant в локальной сети. Один сервер может обслуживать запросы к нескольким сетевым электронным ключам Guardant. Сервер Guardant Net должен быть загружен на том же компьютере, к которому подсоединен сетевой электронный ключ.

Сервер Guardant Net может работать не только как обычное оконное приложение, но и как сервис (служба). Преимущества сервиса состоит в том, что он запускается самой операционной системой во время ее загрузки, для его запуска не нужно выполнять процедуру регистрации на компьютере, и пользователю доступны штатные средства по управлению сервисом.

Порядок установки сетевого ключа выполняется последовательно по шагам:

1. Инсталлируйте драйверы для ключа, на компьютер который будет использоваться в качестве сервера Guardant Net.
2. Подключите ключ Guardant Net к порту этого компьютера.
3. Скопируйте папку "GrdServer" из дистрибутива на жесткий диск, например, в каталог "C:\Program Files". В этой папке находятся сервер Guardant Net и уже настроенный файл конфигурации сервера.
4. Установите и запустите сервер Guardant Net (в качестве сервиса), выполнив команду "C:\Program Files\GrdServer\grdsrv.exe" -i -s. Это действие нужно произвести только один раз. После того как сервис Guardant Net будет успешно запущен, защищенные приложения получат доступ к сетевым ключам Guardant. Сервис будет запускаться автоматически при каждом старте ОС.

Note Примечание.

В пределах локальной сети можно запускать несколько серверов Guardant Net, но они должны находиться на разных компьютерах и обладать уникальными NetBIOS именами.


Настройки на строне клиента

Настройки на стороне клиента | Назад | Вперед
Установка ключей защиты Guardant > Установка сетевого ключа защиты > Настройки на строне клиента |

Чтобы начать работу, защищенное приложение должно зарегистрироваться на сервере ключа. При старте такого приложения запрашивается сервер Guardant Net и приложение продолжает работать только после успешной регистрации на сервере.

Клиент ищет сервер, как с помощью встроенных механизмов Guardant API, так и используя настройки файла конфигурации GnClient.ini. Этот файл должен находиться в одной директории с копией защищенного приложения. При отсутствии файла GnClient.ini всем параметрам сервера Guardant Net присваиваются значения по умолчанию. В этом случае защищенное приложение будет искать сервер со стандартным именем (NVSK_SRVR) и только по протоколу NetBIOS.

Порядок установки сетевого ключа на стороне клиента:

1. Запустите монитор состояния сервера для проверки наличия сервера Guardant Net в сети.
2. Проверьте, что бы в каталоге "Кадастрового Офиса" или "Геомастер" находился файл "NetKey.ini". Этот файл указывает приложениям, что выполняется режима поиска сетевого ключа. В случае, если файла NetKey.ini не будет найден в каталоге, то защищенное приложение будет искать только локальный ключ.
3. Запустите утилиту монитинга сетевого ключа, получите файл настройки (grdclient.ini) и скопируйте его в папку "Кадастрового Офиса". В этом файле находится уже настроенная конфигурации сервера Guardant Net.


Мониторинг сетевого ключа

Мониторинг сетевого ключа | Назад | Вперед
Установка ключей защиты Guardant > Установка сетевого ключа защиты > Мониторинг сетевого ключа |

Для мониторинга состояния сервера Guardant Net и его настройки по сети можно использовать, как специальную утилиту GrdMon.exe, так и обычный web браузер. И сетевой монитор и web браузер предоставляют одинаковую информацию по серверу ключа и одинаковые возможности по его настройке.

При запуске монитор находит по сети все доступные серверы Guardant Net, устанавливает с ними связь и выдает на экран полученную информацию о первом найденном сервере.

Для получения сведений о сервере и изменении его настроек можно также воспользоваться стандартным web интерфейсом, набрав в строке поиска браузере реальный IP адрес (или host hame) компьютера, на котором установлен сервер и сетевой ключ Guardant, и указав порт, по которому сервер ключа принимает http запросы (по умолчанию 3185), например, "http://ххх.ххх.ххх.ххх:3185/".

С помощью ссылки "Получить ini-файл клиента" пользователь получает с сервера файл настройки и должен его самостоятельно скопировать в папку "Кадастрового Офиса".


Мониторинг локального ключа

Мониторинг локального ключа | Назад | Вперед
Установка ключей защиты Guardant > Мониторинг локального ключа |

Работоспособность и наличие подключенного ключа выполняется с помощью утилиты диагностики grddiag.exe, которая находится на диске с дистрибутивом. После запуска утилиты, происходит опрос подключенных ключей к компьютеру, и после прохождения процедуры проверки в таблице выводится информация по всем ключам.

Утилита диагностики позволяет вывести подробный отчет по обнаруженным ключам защиты. При возникновении вопросов о не работоспособном ключе, полученные данные из подробной информации, можно передать разработчикам для диагностики и устранении ошибок.

Note Примечание.

Ключи LPT обнаруживаются после нажатия кнопки "Принудительный поиск".


Система лицензирования

Система лицензирования | Назад | Вперед

Лицензирование программ - это процедура, позволяющая организации или частному лицу установить и использовать программное обеспечение на отдельном компьютере или в сети, в соответствии с лицензионным соглашением. Цель лицензирования - защитить инвестиции предприятия, производящего программное обеспечение.

В программное обеспечение компании ООО "Геотехнологии" встроен специальный механизм, не позволяющий использовать программы в случае нарушения пользователем каких-либо пунктов этого соглашения. К примеру, запуск программ без активации лицензии, обычно приводит к тому, что программное обеспечение работает в демонстрационном режиме, в котором часть функций становится не доступны для пользователя.

Система лицензирования продуктов компании ООО "Геотехнологии" подразумевает под собой регистрацию выданных лицензий в базе данных и активации лицензии на использование программных продуктов компании со стороны пользователей программных продуктов.

В этой главе:

Типы лицензии.

Принципы лицензирования.

Активация лицензии.

Сайт разработчика.


Типы лицензии

Типы лицензии | Назад | Вперед
Система лицензирования > Типы лицензии |

В программных продуктах ООО "Геотехнологии" возможны следующие типы лицензии: персональная и многопользовательская. Перед использованием программного обеспечения, лицензия должна быть активирована.

Персональная лицензия.

Персональная лицензия позволяет использовать программное обеспечение только на том компьютере, где установлен ключ защиты.

Многопользовательская лицензия.

Многопользовательская лицензия позволяет использовать программное обеспечение в сети с сервером ключей защиты, который позволяет работать одновременно на заранее оговоренном количестве компьютеров.


Принципы лицензирования

Принципы лицензирования | Назад | Вперед
Система лицензирования > Принципы лицензирования |

После приобретения программного обеспечения компании ООО "Геотехнологии" и получения дистрибутива, в случае персональной лицензии, пользователь устанавливает на рабочее место приобретенное программное обеспечение. По окончании инсталляции, пользователь должен пройти процедуру активации лицензии, в противном случае, приобретенное программное обеспечение будет работать только в демонстрационном режиме. В случае многопользовательской лицензии, пользователю необходимо установить сервер ключа защиты и активизировать многопользовательскую лицензию на этом компьютере. Защищенные приложения могут устанавливаться на рабочих станциях по мере необходимости.

В программное обеспечение встроен специальный механизм, не позволяющий использовать программы, не прошедшие активации лицензии. В качестве такого механизма выбрана проверка наличия ключа защиты.

Процедура активации лицензии заключается в записи в память ключа защиты информации о конкретной версии программного обеспечения. По окончанию активации лицензии пользователь должен обязательно переслать код-подтверждение завершения активации разработчику программного обеспечения, для того, чтобы, в дальнейшем у него имелась возможность обновить ключ защиты при изменении программного обеспечения.

Производитель в праве выпустить новую версию программного обеспечения, которое предусматривает приобретение новой лицензии и ее активацию.

Note Примечание.

Получение и обновление дистрибутива может быть выполнено средствами интернет.


Активация лицензии

Активация лицензии | Назад | Вперед
Система лицензирования > Активация лицензии |

Активация лицензий - это обмен информацией пользователя с разработчиком программного обеспечения, в результате которого, пользователь обновляет память ключа защиты в соответствии с приобретенной лицензией.

В целом процесс активации лицензии не зависит от типа выбранной лицензии. В случае использования персональной лицензии пользователь выполняет активацию на рабочем месте, а при использовании многопользовательской лицензии, процесс активации должен проходить на компьютере на котором установлен сетевой ключ защиты и сервер ключей защиты.

Активация лицензий выполняется с помощью утилиты дистанционного программирования ключей Guardant (этот файл входит в комплект поставки защищенного приложения). Для успешной работы клиентской утилиты удаленного обновления, на компьютере пользователя, должны быть установлены драйверы ключа защиты, к порту компьютера должен быть подсоединен ключ с кодами доступа разработчика, который поставляется вместе приобретенным программным обеспечением. В том случае, если у конечного пользователя установлено несколько защищенных программ одного разработчика, то в порту необходимо оставить только тот один ключ, который требует обновления.

Активации лицензии состоит из следующих этапов: Создание запроса на обновление, Обновление памяти ключа и Передача кода-подтверждения разработчику.

В этом разделе:

Создание запроса на обновление.

Обновление памяти ключа.

Передача кода-подтверждения разработчику.


Создание запроса на обновление

Создание запроса на обновление | Назад | Вперед
Система лицензирования > Активация лицензии > Создание запроса на обновление |

В том случае, если необходимо активизировать персональную лицензию, то пользователь запускает защищенную программу, и в меню "Лицензирование" выбирает пункт "Обновить лицензию". В том случае, если необходимо провести активацию многопользовательской лицензии, то необходимо напрямую запустить утилиту GSRemote.exe на компьютере, на котором установлен ключ защиты и запущен сервер ключей защиты. В остальном, работа с утилитой дистанционного программирования ключей не будет отличаться.

Порядок создания запроса на обновление выполняется последовательно по шагам:

1. Отсоедините подключенные ключи защиты от портов компьютера, оставив только тот, для которого необходимо активизировать лицензию.

2. Запустите защищенное программное обеспечение, и с помощью меню "Лицензирование", выберите пункт "Обновить лицензию".

3. После запуска утилиты на экране появится форма, на которой необходимо выбрать пункт "Начать новую операцию обновления ключа". Нажмите кнопку "Далее" для продолжения работы.

4. Утилитой удаленного программирования будет сгенерирован запрос на обновление (число-вопрос) - последовательность шестнадцатеричных символов, содержащая информацию о ключе.

Запрос на обновление можно сохранить в файле - кнопка "В файл", скопировать в буфер обмена с помощью кнопки "В буфер" или сразу сформировать почтовое сообщение для разработчиков с помощью кнопки "По почте".

5. Полученную информацию пользователь должен передать разработчику на адрес e-mail support@geo-office.ru.

В письме, кроме сгенерированного числа-вопроса на обновление ключа защиты, необходимо указать информацию: Полное название организации или имя физического лица, Адрес, Телефон, Контактное лицо. Запросы без этой информации отделом технического обеспечения обрабатываться не будут.

6. После передачи запроса, работу утилиты можно завершить, кнопка "Завершить", до получения ответа от разработчиков программного обеспечения.

Note Примечание.

Данные в числе-вопросе передаются в закодированном виде и могут быть использованы только один раз.


Обновление памяти ключа

Обновление памяти ключа | Назад | Вперед
Система лицензирования > Активация лицензии > Обновление памяти ключа |

После получения по электронной почте от разработчиков программного обеспечения числа-ответа, пользователь должен обновить память ключа. При этом, выполняется ряд проверок параметров ключа (ID ключа, Общий код и некоторые другие). Этим исключается возможность подмены обновляемого ключа.

После обновления памяти ключа, пользователь должен передать разработчику программного обеспечения код-подтверждение об успешном завершении операции обновления памяти ключа.

Порядок обновление памяти ключа выполняется последовательно по шагам:

1. Запустите защищенное программное обеспечение, и с помощью меню "Лицензирование", выберите пункт "Обновить лицензию".

2. После запуска утилиты на экране появится страница, на которой необходимо выбрать пункт "Продолжить операцию обновления ключа, инициированную во время предыдущего сеанса". Нажмите кнопку "Далее" для продолжения работы.

3. На экране появится страница мастера, содержащая поле для ввода числа-ответа.

Вставьте в поле для ввода полученный от разработчиков по почте число-ответ. Ввод дампа обновления может происходить следующими способами. Из буфера обмена, когда полученный от разработчика ответ можно скопировать в буфер обмена, а затем вставить его в поле ввода с помощью кнопки "Из буфера". Из файла, когда полученный от разработчика ответ, предварительно сохраняется на локальном диске пользователя, а затем, с помощью кнопки "Из файла…", выбирается этот сохраненный файл.

4. После ввода дампа обновления нажмите кнопку "Далее" для продолжения работы.

На этом активация лицензии не заканчивается. Пользователь должен передать кода-подтверждение завершения операции разработчику. Без передачи кода-подтверждения, конечный пользователь лишается возможности дальнейшего обновления ключа, в случае изменении в программном обеспечении.

Note Примечание.

Данные в числе-ответе передаются в закодированном виде и могут быть использованы только один раз.


Передача кода-подтверждения разработчику

Передача кода-подтверждения разработчику | Назад
Система лицензирования > Активация лицензии > Передача кода-подтверждения разработчику |

По окончанию успешной процедуры обновления памяти ключа защиты, программа генерирует код-подтверждение завершения активации. Пользователь должен обязательно переслать код-подтверждение завершения активации разработчику, для того, чтобы, в дальнейшем имелась возможность обновить ключ защиты при изменении программного обеспечения.

Порядок передачи кода-подтверждения разработчику выполняется последовательно по шагам:

1. На предыдущем этапе, утилитой дистанционного обновления будет произведена операция по обновлению памяти ключа. Затем на экране появится последняя страница мастера с итогами выполнения операции и сформированный финальный код-подтверждение, содержащий информацию о результате обновления (успешно/неудачно).

2. Полученную информацию пользователь должен передать разработчику на адрес e-mail support@geo-office.ru.

Код-подтверждение завершения активации можно сохранить в файле - кнопка "В файл", скопировать в буфер обмена с помощью кнопки "В буфер" или сразу сформировать почтовое сообщение для разработчиков приложения с помощью кнопки "По почте".

3. После успешной отправки кода-подтверждения, нажмите "Готово" для закрытия утилиты дистанционного программирования ключей.

Note Примечание.

Данные в коде-подтверждение завершения активации передаются в закодированном виде и могут быть использованы только один раз.
Назад