Установка ключей защиты Guardant

 Вперед

Электронный ключ - это устройство, предназначенное для защиты программ и данных от несанкционированного использования и тиражирования. Электронный ключ подсоединяется к параллельному (LPT) или USB-порту компьютера.

Различаются сетевые и локальные ключи защиты. Локальный ключ устанавливается на один компьютер и позволяет работать с защищенным приложением только на этом рабочем месте. Сетевой ключ устанавливается на сервер или отдельный компьютер, который будет выступать в качестве сервера ключей защиты, и позволяет одновременно нескольким пользователям работать с защищенным приложением. Количество рабочих станций, которые могут одновременно работать с такими приложениями, ограничено количеством лицензий на каждом конкретном электронном ключе.

В этой главе:

Инсталляция драйверов Guardant.

Порядок установки ключей USB.

Порядок установки ключей LPT.

Установка сетевого ключа защиты.

Мониторинг локального ключа.
Вперед


Инсталляция драйверов Guardant

Инсталляция драйверов Guardant | Назад | Вперед
Установка ключей защиты Guardant > Инсталляция драйверов Guardant |

Установки как локальных, так и сетевых ключей защиты, начинается с инсталляции драйверов для ключей защиты.

Драйверы для ключей Guardant необходимы для работы защищенных программ, которые обращающихся к этому электронному ключу. Во время установки драйвера все приложения должны быть закрыты во избежание ошибки разделения файлов.

Инсталляция драйверов Guardant выполняется с помощью достаточно простого мастера установки и состоит из ряда последовательных шагов:

1. Отключите все USB ключи от портов компьютера.
2. Запустите на исполнение файл (GrdDriver\GrdDriversRU.msi или GrdDriver\Setup.exe), который находятся на диске с дистрибутивом, и следуйте указаниям программы установки.
3. По окончании процесса инсталляции закройте мастер установки.

В том случае, если в системе уже был установлен драйвер Guardant, то после запуска программы установки драйверов, пользователю будут предложены варианты: переустановить или удалить драйвер Guardant. Для "старых" версий драйверов, необходимо переустановить драйвера.

После инсталляции драйверов, следует произвести подключение ключа к разъему компьютера. Более подробно об установки ключей смотри: Порядок установки ключей USB, Порядок установки ключей LPT, Установка сервера ключей защиты.

Note Примечание.

Пользователь, который устанавливает драйверы для ключей защиты, должен обладать правами администратора.
Назад Вперед


Порядок установки ключей USB

Порядок установки ключей USB | Назад | Вперед
Установка ключей защиты Guardant > Порядок установки ключей USB |

Подключение и отключение ключей Guardant USB может производиться, как при включенном компьютере, так и при выключенном.

USB-ключ следует подсоединять к порту только после инсталляции драйвера Guardant. Если ключ был подсоединен до установки драйвера, и запустился стандартный "Мастер установки USB-устройств", то необходимо извлечь ключ из порта и отменить работу мастера.

Порядок установки ключа USB выполняется последовательно по шагам:

1. Инсталлируйте драйверы для ключа Guardant.
2. При необходимости перезагрузите компьютер.
3. Подсоедините ключ Guardant USB к свободному USB порту. После обнаружения нового устройства для него будут применены установленные драйвера.
4. Убедитесь в том, что защищенное приложение функционирует правильно.

Возможно, на шаге 3 не будет обнаружено новое устройство. В этом случае нужно зайти в "Управление компьютером | Диспетчер устройств | Guardant dongles", щелкнуть на "Guardant Stealth/Net II USB dongle" и удалить его, а затем вновь повторить шаг 3.

Свидетельством того, что USB-ключ был успешно инициализирован операционной системой, является световая индикация ключа. Кроме того, ключ должен появиться в списке оборудования Диспетчера устройств.

Note Примечание.

Работоспособность и наличие ключа можно выполнить с помощью утилиты диагностики.


Порядок установки ключей LPT

Порядок установки ключей LPT | Назад | Вперед
Установка ключей защиты Guardant > Порядок установки ключей LPT |

Подключение и отключение ключей Guardant LPT может производиться, только при выключенном компьютере. Если на компьютере имеется несколько параллельных портов, можно подключать электронный ключ к любому из них.

Порядок установки LPT-ключ выполняется последовательно по шагам:

1. Выключите питание компьютера и периферийных устройств, подключенных к параллельному порту (принтер, сканер).
2. Отключите периферийное устройство от параллельного порта. Разъем электронного ключа типа "вилка" подключите к параллельному порту компьютера. Электронные ключи поддерживают каскадное подключение, т.е. последовательно один к другому (до 10 штук), при этом все они будут доступны для использования. К разъему электронного ключа типа "розетка" подключите периферийное устройство.
3. Включите компьютер и загрузите операционную систему.
4. Инсталлируйте драйверы для ключа Guardant.
5. При необходимости перезагрузите компьютер.
6. Убедитесь в том, что защищенное приложение функционирует правильно.

Note Примечание.

Работоспособность и наличие ключа можно выполнить с помощью утилиты диагностики.


Установка сетевого ключа защиты

Установка сетевого ключа защиты | Назад | Вперед
Установка ключей защиты Guardant > Установка сетевого ключа защиты |

Установка сетевого ключа выполняется на стороне сервера и на стороне клиента. В начале работы по установке, необходимо определить компьютер на котором будет находиться электронный ключ Guardant Net и программный сервер. Это может быть как сервер сети, так и любая рабочая станция.

Защищенное приложение обращается к электронному ключу Guardant Net через специальный программный сервер. Чтобы начать работу, приложение должно зарегистрироваться на сервере ключа. В ходе регистрации сервер проверяет, подсоединен ли к компьютеру ключ с запрашиваемыми параметрами, и уменьшает на 1 значение ресурса лицензий ключа. Если регистрация прошла успешно, приложение нормально работает, в противном случае клиенту возвращается соответствующая ошибка. При завершении работы приложение снимает свою регистрацию с сервера, при этом производится увеличение на 1 значения ресурса лицензий ключа.

Число одновременно работающих клиентских приложений ограничивается сетевым ресурсом ключей Guardant Net. Реальный сетевой ресурс программируется разработчиком перед передачей защищенного приложения и ключа конечному пользователю.

В этом разделе:

Установка сервера ключей защиты.

Настройки на стороне клиента.

Мониторинг сетевого ключа.

Note Примечание.

Подробнее о сервере Guardant Net, его установки и настройки смотри в документе "Руководство системного администратора Guardant Net.pdf".


Установка сервера ключей защиты

Установка сервера ключей защиты | Назад | Вперед
Установка ключей защиты Guardant > Установка сетевого ключа защиты > Установка сервера ключей защиты |

Сервер Guardant Net обеспечивает связь между защищенным сетевым приложением и сетевым ключом Guardant в локальной сети. Один сервер может обслуживать запросы к нескольким сетевым электронным ключам Guardant. Сервер Guardant Net должен быть загружен на том же компьютере, к которому подсоединен сетевой электронный ключ.

Сервер Guardant Net может работать не только как обычное оконное приложение, но и как сервис (служба). Преимущества сервиса состоит в том, что он запускается самой операционной системой во время ее загрузки, для его запуска не нужно выполнять процедуру регистрации на компьютере, и пользователю доступны штатные средства по управлению сервисом.

Порядок установки сетевого ключа выполняется последовательно по шагам:

1. Инсталлируйте драйверы для ключа, на компьютер который будет использоваться в качестве сервера Guardant Net.
2. Подключите ключ Guardant Net к порту этого компьютера.
3. Скопируйте папку "GrdServer" из дистрибутива на жесткий диск, например, в каталог "C:\Program Files". В этой папке находятся сервер Guardant Net и уже настроенный файл конфигурации сервера.
4. Установите и запустите сервер Guardant Net (в качестве сервиса), выполнив команду "C:\Program Files\GrdServer\grdsrv.exe" -i -s. Это действие нужно произвести только один раз. После того как сервис Guardant Net будет успешно запущен, защищенные приложения получат доступ к сетевым ключам Guardant. Сервис будет запускаться автоматически при каждом старте ОС.

Note Примечание.

В пределах локальной сети можно запускать несколько серверов Guardant Net, но они должны находиться на разных компьютерах и обладать уникальными NetBIOS именами.


Настройки на строне клиента

Настройки на стороне клиента | Назад | Вперед
Установка ключей защиты Guardant > Установка сетевого ключа защиты > Настройки на строне клиента |

Чтобы начать работу, защищенное приложение должно зарегистрироваться на сервере ключа. При старте такого приложения запрашивается сервер Guardant Net и приложение продолжает работать только после успешной регистрации на сервере.

Клиент ищет сервер, как с помощью встроенных механизмов Guardant API, так и используя настройки файла конфигурации GnClient.ini. Этот файл должен находиться в одной директории с копией защищенного приложения. При отсутствии файла GnClient.ini всем параметрам сервера Guardant Net присваиваются значения по умолчанию. В этом случае защищенное приложение будет искать сервер со стандартным именем (NVSK_SRVR) и только по протоколу NetBIOS.

Порядок установки сетевого ключа на стороне клиента:

1. Запустите монитор состояния сервера для проверки наличия сервера Guardant Net в сети.
2. Проверьте, что бы в каталоге "Кадастрового Офиса" или "Геомастер" находился файл "NetKey.ini". Этот файл указывает приложениям, что выполняется режима поиска сетевого ключа. В случае, если файла NetKey.ini не будет найден в каталоге, то защищенное приложение будет искать только локальный ключ.
3. Запустите утилиту монитинга сетевого ключа, получите файл настройки (grdclient.ini) и скопируйте его в папку "Кадастрового Офиса". В этом файле находится уже настроенная конфигурации сервера Guardant Net.


Мониторинг сетевого ключа

Мониторинг сетевого ключа | Назад | Вперед
Установка ключей защиты Guardant > Установка сетевого ключа защиты > Мониторинг сетевого ключа |

Для мониторинга состояния сервера Guardant Net и его настройки по сети можно использовать, как специальную утилиту GrdMon.exe, так и обычный web браузер. И сетевой монитор и web браузер предоставляют одинаковую информацию по серверу ключа и одинаковые возможности по его настройке.

При запуске монитор находит по сети все доступные серверы Guardant Net, устанавливает с ними связь и выдает на экран полученную информацию о первом найденном сервере.

Для получения сведений о сервере и изменении его настроек можно также воспользоваться стандартным web интерфейсом, набрав в строке поиска браузере реальный IP адрес (или host hame) компьютера, на котором установлен сервер и сетевой ключ Guardant, и указав порт, по которому сервер ключа принимает http запросы (по умолчанию 3185), например, "http://ххх.ххх.ххх.ххх:3185/".

С помощью ссылки "Получить ini-файл клиента" пользователь получает с сервера файл настройки и должен его самостоятельно скопировать в папку "Кадастрового Офиса".


Мониторинг локального ключа

Мониторинг локального ключа | Назад
Установка ключей защиты Guardant > Мониторинг локального ключа |

Работоспособность и наличие подключенного ключа выполняется с помощью утилиты диагностики grddiag.exe, которая находится на диске с дистрибутивом. После запуска утилиты, происходит опрос подключенных ключей к компьютеру, и после прохождения процедуры проверки в таблице выводится информация по всем ключам.

Утилита диагностики позволяет вывести подробный отчет по обнаруженным ключам защиты. При возникновении вопросов о не работоспособном ключе, полученные данные из подробной информации, можно передать разработчикам для диагностики и устранении ошибок.

Note Примечание.

Ключи LPT обнаруживаются после нажатия кнопки "Принудительный поиск".
Назад